Redistribution ospf v2-v3 / Rip v1 - Ripng

Publié le par joseph

Redistribution-ospf-v2-v3-_Rip-v1---Ripng.jpg
clicquer sur l'image pour agrandir


config :

R1

hostname R1

ip cef
ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 ip address 172.16.1.145 255.255.255.240
 duplex auto
 speed auto
 ipv6 address 2001:DB8:0:190::1/64
 ipv6 ospf 10 area 0
 no shut
 exit

interface FastEthernet0/1
 ip address 172.16.1.97 255.255.255.224
 duplex auto
 speed auto
 ipv6 address 2001:DB8:0:160::1/64
 ipv6 rip joseph enable
 no shut
 exit

router ospf 10
 router-id 1.1.1.2
 redistribute rip metric 50 subnets
 network 172.16.1.0 0.0.0.255 area 0
 exit

router rip
 redistribute ospf 10 metric 2
 passive-interface FastEthernet0/0
 network 172.16.0.0
 exit

ipv6 router ospf 10
 router-id 1.1.1.3
 redistribute rip joseph metric 50
 exit

ipv6 router rip joseph
 redistribute ospf 10 metric 2

end

wr

-------------------------

R2

hostname R2

 

ip cef
ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 ip address 172.16.1.146 255.255.255.240
 duplex auto
 speed auto
 ipv6 address 2001:DB8:0:190::2/64
 ipv6 ospf 10 area 0
 no shut
 exit

interface Loopback0
 ip address 172.16.1.161 255.255.255.240
 ipv6 address 2001:DB8:0:AA1::1/64
 ipv6 ospf 10 area 0
 no shut
 exit
interface Loopback1
 ip address 172.16.1.225 255.255.255.240
 ipv6 address 2001:DB8:0:BB1::1/64
 ipv6 ospf 10 area 0
 no shut
 exit
interface Loopback2
 ip address 172.16.1.129 255.255.255.240
 ipv6 address 2001:DB8:0:CC1::1/64
 ipv6 ospf 10 area 0
 no shut
 exit

interface Loopback3
 ip address 172.16.1.193 255.255.255.240
 ipv6 address 2001:DB8:0:DD1::1/64
 ipv6 ospf 10 area 0
 no shut
 exit

router ospf 10
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 exit

ipv6 router ospf 10
 router-id 1.1.1.2
 log-adjacency-changes

end

wr

--------------------------------------------

 

R3

hostname R3

ip cef
ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 ip address 172.16.1.98 255.255.255.224
 duplex auto
 speed auto
 ipv6 address 2001:DB8:0:160::2/64
 ipv6 rip joseph enable
 no shut
 exit

interface Loopback0
 ip address 172.16.2.33 255.255.255.224
 ipv6 address 2001:DB8:0:10::1/64
 ipv6 rip joseph enable
 no shut
 exit

interface Loopback1
 ip address 172.16.2.65 255.255.255.224
 ipv6 address 2001:DB8:0:20::1/64
 ipv6 rip joseph enable
 no shut
 exit

interface Loopback2
 ip address 172.16.2.129 255.255.255.224
 ipv6 address 2001:DB8:0:30::1/64
 ipv6 rip joseph enable
 no shut
 exit

 
router rip
 network 172.16.0.0


end

wr

----------------------------------------------------

VERIFICATIONS /


R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 9 subnets, 3 masks
O       172.16.1.161/32 [110/11] via 172.16.1.146, 01:03:34, FastEthernet0/0
C       172.16.1.144/28 is directly connected, FastEthernet0/0
O       172.16.1.129/32 [110/11] via 172.16.1.146, 01:03:34, FastEthernet0/0
R       172.16.2.128/27 [120/1] via 172.16.1.98, 00:00:23, FastEthernet0/1
O       172.16.1.225/32 [110/11] via 172.16.1.146, 01:03:34, FastEthernet0/0
O       172.16.1.193/32 [110/11] via 172.16.1.146, 01:03:34, FastEthernet0/0
R       172.16.2.32/27 [120/1] via 172.16.1.98, 00:00:23, FastEthernet0/1
C       172.16.1.96/27 is directly connected, FastEthernet0/1
R       172.16.2.64/27 [120/1] via 172.16.1.98, 00:00:23, FastEthernet0/1
R1#
R1#sh ipv6 route
IPv6 Routing Table - 13 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
R   2001:DB8:0:10::/64 [120/2]
     via FE80::C202:EFF:FEAC:0, FastEthernet0/1
R   2001:DB8:0:20::/64 [120/2]
     via FE80::C202:EFF:FEAC:0, FastEthernet0/1
R   2001:DB8:0:30::/64 [120/2]
     via FE80::C202:EFF:FEAC:0, FastEthernet0/1
C   2001:DB8:0:160::/64 [0/0]
     via ::, FastEthernet0/1
L   2001:DB8:0:160::1/128 [0/0]
     via ::, FastEthernet0/1
C   2001:DB8:0:190::/64 [0/0]
     via ::, FastEthernet0/0
L   2001:DB8:0:190::1/128 [0/0]
     via ::, FastEthernet0/0
O   2001:DB8:0:AA1::1/128 [110/10]
     via FE80::C201:EFF:FEAC:0, FastEthernet0/0
O   2001:DB8:0:BB1::1/128 [110/10]
     via FE80::C201:EFF:FEAC:0, FastEthernet0/0
O   2001:DB8:0:CC1::1/128 [110/10]
     via FE80::C201:EFF:FEAC:0, FastEthernet0/0
O   2001:DB8:0:DD1::1/128 [110/10]
     via FE80::C201:EFF:FEAC:0, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R1#

--------------------
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
C       172.16.1.160/28 is directly connected, Loopback0
C       172.16.1.144/28 is directly connected, FastEthernet0/0
C       172.16.1.128/28 is directly connected, Loopback2
O E2    172.16.2.128/27 [110/50] via 172.16.1.145, 01:04:46, FastEthernet0/0
C       172.16.1.224/28 is directly connected, Loopback1
C       172.16.1.192/28 is directly connected, Loopback3
O E2    172.16.2.32/27 [110/50] via 172.16.1.145, 01:04:46, FastEthernet0/0
O       172.16.1.96/27 [110/20] via 172.16.1.145, 01:04:46, FastEthernet0/0
O E2    172.16.2.64/27 [110/50] via 172.16.1.145, 01:04:46, FastEthernet0/0
R2#

R2#sh ipv6 route
IPv6 Routing Table - 15 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OE2  2001:DB8:0:10::/64 [110/50]
     via FE80::C200:EFF:FEAC:0, FastEthernet0/0
OE2  2001:DB8:0:20::/64 [110/50]
     via FE80::C200:EFF:FEAC:0, FastEthernet0/0
OE2  2001:DB8:0:30::/64 [110/50]
     via FE80::C200:EFF:FEAC:0, FastEthernet0/0
C   2001:DB8:0:190::/64 [0/0]
     via ::, FastEthernet0/0
L   2001:DB8:0:190::2/128 [0/0]
     via ::, FastEthernet0/0
C   2001:DB8:0:AA1::/64 [0/0]
     via ::, Loopback0
L   2001:DB8:0:AA1::1/128 [0/0]
     via ::, Loopback0
C   2001:DB8:0:BB1::/64 [0/0]
     via ::, Loopback1
L   2001:DB8:0:BB1::1/128 [0/0]
     via ::, Loopback1
C   2001:DB8:0:CC1::/64 [0/0]
     via ::, Loopback2
L   2001:DB8:0:CC1::1/128 [0/0]
     via ::, Loopback2
C   2001:DB8:0:DD1::/64 [0/0]
     via ::, Loopback3
L   2001:DB8:0:DD1::1/128 [0/0]
     via ::, Loopback3
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R2#
R2#sh ipv6 ospf neighbor

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
1.1.1.3           1   FULL/DR         00:00:31    4               FastEthernet0/0
R2#
R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.2           1   FULL/DR         00:00:33    172.16.1.145    FastEthernet0/0
R2#


les pings :
R2#ping ipv6 2001:DB8:0:10::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:0:10::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/93/212 ms
R2#
R2#ping ipv6 2001:DB8:0:20::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:0:20::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/80/116 ms
R2#ping ipv6 2001:DB8:0:30::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:0:30::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/67/84 ms
R2#
R2#ping 172.16.2.33

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/84/152 ms
R2#ping 172.16.2.65

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.65, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/101/156 ms
R2#ping 172.16.2.129

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.129, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/83/132 ms


note :
si vous avez des difficultées pour faire des pings , configurer les routes par defaut sur R3 pointant vers R1 et le tour est joué

ex : ip route 0.0.0. 0.0.0. 172.16.1.97
      ipv6 route ::/0 2001:DB8:0:160::1



 


Pour être informé des derniers articles, inscrivez vous :
Commenter cet article