isis topology config

Publié le par joseph


Capt 100314 224357 001
                                                                     clicquer pour agrandir

configuartion:


hostname R1

no aaa new-model
memory-size iomem 5

ip cef

interface FastEthernet0/0
 description connection-to-R7
 ip address 10.1.2.1 255.255.255.0
 ip router isis
 duplex auto
 speed auto
 isis circuit-type level-2-only
no shut
exit

!
interface Serial0/0
 description connection-to-R2
 ip address 191.1.1.13 255.255.255.252
 ip router isis
 encapsulation ppp
 clock rate 56000
no shut
exit

!
interface Serial0/1
 description connection-to-R3
 ip address 191.1.1.2 255.255.255.252
 ip router isis
 encapsulation ppp
 clock rate 56000
no shut
exit
!
interface Serial0/2
 description connection-to-R4
 ip address 191.1.1.21 255.255.255.252
 ip router isis
 encapsulation ppp
 clock rate 56000
no shut
exit

router isis
 net 49.0004.1111.1111.1111.00
 is-type level-2-only

end

------------------------
hostname R2

interface FastEthernet0/0
description connection-to-R9
ip address 192.168.1.2 255.255.255.0
ip router isis
duplex auto
speed auto
isis circuit-type level-2-only
no shut
exit

interface Serial0/0
description connection-to-R1
ip address 191.1.1.14 255.255.255.252
ip router isis
encapsulation ppp
no shut
exit


interface Serial0/1
description connection-to-R3
ip address 191.1.1.6 255.255.255.252
ip router isis
encapsulation ppp
no shut
exit

interface Serial0/2
description connection-to-R4
ip address 191.1.1.17 255.255.255.252
ip router isis
encapsulation ppp
clock rate 56000
no shut exit


router isis
 net 49.0003.2222.2222.2222.00
 is-type level-2-only
exit
!
end

wr

-----------------------
hostname R3

interface FastEthernet0/0
description connection-to-R6
ip address 192.168.0.2 255.255.255.0
ip router isis
duplex auto
speed auto
no shut
exit

interface Serial0/0
description connection-to-R4
ip address 191.1.1.9 255.255.255.252
ip router isis
encapsulation ppp
clock rate 56000
no shut
exit

interface FastEthernet0/1
description connection-to-R5
ip address 10.1.1.2 255.255.255.0
ip router isis
duplex auto
speed auto
no shut
exit

interface Serial0/1
description connection-to-R1
ip address 191.1.1.1 255.255.255.252
ip router isis
encapsulation ppp
clock rate 56000
no shut
exit

interface Serial0/2
description connection-to-R2
ip address 191.1.1.5 255.255.255.252
ip router isis
encapsulation ppp
clock rate 56000
no shut exit

router isis
 net 49.0001.3333.3333.3333.00

end
wr

--------------------

hostname R4

interface FastEthernet0/0
description connection-to-R8
ip address 192.168.2.2 255.255.255.0
ip router isis
duplex auto
speed auto
isis circuit-type level-1
no shut
exit

!
interface Serial0/0
description connection-to-R3
ip address 191.1.1.10 255.255.255.252
ip router isis
encapsulation ppp
no shut
exit
!

!
interface Serial0/1
description connection-to-R1
ip address 191.1.1.22 255.255.255.252
ip router isis
encapsulation ppp
clock rate 56000
no shut
exit

interface Serial0/2
description connection-to-R2
ip address 191.1.1.18 255.255.255.252
ip router isis
encapsulation ppp
clock rate 56000
no shut
exit

 

router isis
 net 49.0002.4444.4444.4444.00

!
end

wr

----------------
hostname R5

interface FastEthernet0/0
description connection-to-R3
ip address 10.1.1.1 255.255.255.0
ip router isis
duplex auto
speed auto
no shut
exit

!
router isis
net 49.0001.5555.5555.5555.00
is-type level-1

end

wr
 -----------------
hostname R6

interface FastEthernet0/0
description connection-to-R3
ip address 192.168.0.1 255.255.255.0
ip router isis
duplex auto
speed auto
no shut
exit

router isis
net 49.0001.6666.6666.6666.00
is-type level-1

end

wr

----------------
hostname R7

interface FastEthernet0/0
description connection-to-R1
ip address 10.1.2.2 255.255.255.0
ip router isis
duplex auto
speed auto
isis circuit-type level-2-only
no shut
exit

router isis
 net 49.0004.7777.7777.7777.00
 is-type level-2-only

end

wr

-------------------------

hostname R8

interface FastEthernet0/0
description connection-to-R4
ip address 192.168.2.1 255.255.255.0
ip router isis
duplex auto
speed auto
isis circuit-type level-1
no shut
exit

router isis
net 49.0002.8888.8888.8888.00
is-type level-1

end

wr

-------------------------

hostname R9

interface FastEthernet0/0
description connection-to-R2
ip address 192.168.1.1 255.255.255.0
ip router isis
duplex auto
speed auto
isis circuit-type level-2-only
no shut
exit

router isis
net 49.0003.9999.9999.9999.00
is-type level-2-only

end

wr

--------------------------

test :
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     191.1.0.0/16 is variably subnetted, 10 subnets, 2 masks
i L2    191.1.1.20/30 [115/20] via 191.1.1.10, Serial0/0
                      [115/20] via 191.1.1.2, Serial0/1
i L2    191.1.1.16/30 [115/20] via 191.1.1.10, Serial0/0
                      [115/20] via 191.1.1.6, Serial0/2
i L2    191.1.1.13/32 [115/20] via 191.1.1.6, Serial0/2
i L2    191.1.1.12/30 [115/20] via 191.1.1.6, Serial0/2
                      [115/20] via 191.1.1.2, Serial0/1
C       191.1.1.10/32 is directly connected, Serial0/0
C       191.1.1.8/30 is directly connected, Serial0/0
C       191.1.1.6/32 is directly connected, Serial0/2
C       191.1.1.4/30 is directly connected, Serial0/2
C       191.1.1.2/32 is directly connected, Serial0/1
C       191.1.1.0/30 is directly connected, Serial0/1
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L2    10.1.2.0/24 [115/20] via 191.1.1.2, Serial0/1
C       10.1.1.0/24 is directly connected, FastEthernet0/1
i L2    10.1.2.2/32 [115/20] via 191.1.1.2, Serial0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/0
i L2 192.168.1.0/24 [115/20] via 191.1.1.6, Serial0/2
i L2 192.168.2.0/24 [115/20] via 191.1.1.10, Serial0/0
R3#

R3#sh clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R1             Se0/1       *PPP*               Up     29        L2   IS-IS
R2             Se0/2       *PPP*               Up     28        L2   IS-IS
R4             Se0/0       *PPP*               Up     23        L2   IS-IS
R5             Fa0/1       c004.04fc.0000      Up     8         L1   IS-IS
R6             Fa0/0       c005.04fc.0000      Up     8         L1   IS-IS
R3#

------------

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     191.1.0.0/16 is variably subnetted, 9 subnets, 2 masks
C       191.1.1.22/32 is directly connected, Serial0/2
C       191.1.1.20/30 is directly connected, Serial0/2
i L2    191.1.1.16/30 [115/20] via 191.1.1.22, Serial0/2
                      [115/20] via 191.1.1.14, Serial0/0
C       191.1.1.14/32 is directly connected, Serial0/0
C       191.1.1.12/30 is directly connected, Serial0/0
i L2    191.1.1.8/30 [115/20] via 191.1.1.22, Serial0/2
                     [115/20] via 191.1.1.1, Serial0/1
i L2    191.1.1.4/30 [115/20] via 191.1.1.14, Serial0/0
C       191.1.1.1/32 is directly connected, Serial0/1
C       191.1.1.0/30 is directly connected, Serial0/1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.1.2.0 is directly connected, FastEthernet0/0
i L2    10.1.1.0 [115/20] via 191.1.1.1, Serial0/1
i L2 192.168.0.0/24 [115/20] via 191.1.1.1, Serial0/1
i L2 192.168.1.0/24 [115/20] via 191.1.1.14, Serial0/0
i L2 192.168.2.0/24 [115/20] via 191.1.1.22, Serial0/2
R1#

R1#sh clns nei

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R2             Se0/0       *PPP*               Up     26        L2   IS-IS
R3             Se0/1       *PPP*               Up     28        L2   IS-IS
R4             Se0/2       *PPP*               Up     23        L2   IS-IS
R7             Fa0/0       c006.04fc.0000      Up     8         L2   IS-IS
R1#

----------------

R2# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     191.1.0.0/16 is variably subnetted, 10 subnets, 2 masks
i L2    191.1.1.20/30 [115/20] via 191.1.1.18, Serial0/2
                      [115/20] via 191.1.1.13, Serial0/0
C       191.1.1.18/32 is directly connected, Serial0/2
C       191.1.1.16/30 is directly connected, Serial0/2
C       191.1.1.13/32 is directly connected, Serial0/0
C       191.1.1.12/30 is directly connected, Serial0/0
i L2    191.1.1.8/30 [115/20] via 191.1.1.18, Serial0/2
                     [115/20] via 191.1.1.5, Serial0/1
C       191.1.1.5/32 is directly connected, Serial0/1
C       191.1.1.4/30 is directly connected, Serial0/1
i L2    191.1.1.1/32 [115/20] via 191.1.1.13, Serial0/0
i L2    191.1.1.0/30 [115/20] via 191.1.1.13, Serial0/0
                     [115/20] via 191.1.1.5, Serial0/1
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L2    10.1.2.0/24 [115/20] via 191.1.1.13, Serial0/0
i L2    10.1.1.0/24 [115/20] via 191.1.1.5, Serial0/1
i L2    10.1.2.2/32 [115/20] via 191.1.1.13, Serial0/0
i L2 192.168.0.0/24 [115/20] via 191.1.1.5, Serial0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0
i L2 192.168.2.0/24 [115/20] via 191.1.1.18, Serial0/2
R2#

R2#sh clns nei

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R1             Se0/0       *PPP*               Up     23        L2   IS-IS
R3             Se0/1       *PPP*               Up     22        L2   IS-IS
R4             Se0/2       *PPP*               Up     29        L2   IS-IS
R9             Fa0/0       c008.02bc.0000      Up     9         L2   IS-IS
R2#

-----------
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     191.1.0.0/16 is variably subnetted, 11 subnets, 2 masks
C       191.1.1.21/32 is directly connected, Serial0/1
C       191.1.1.20/30 is directly connected, Serial0/1
C       191.1.1.17/32 is directly connected, Serial0/2
C       191.1.1.16/30 is directly connected, Serial0/2
i L2    191.1.1.13/32 [115/20] via 191.1.1.17, Serial0/2
i L2    191.1.1.12/30 [115/20] via 191.1.1.21, Serial0/1
                      [115/20] via 191.1.1.17, Serial0/2
C       191.1.1.9/32 is directly connected, Serial0/0
C       191.1.1.8/30 is directly connected, Serial0/0
i L2    191.1.1.4/30 [115/20] via 191.1.1.17, Serial0/2
i L2    191.1.1.1/32 [115/20] via 191.1.1.21, Serial0/1
i L2    191.1.1.0/30 [115/20] via 191.1.1.21, Serial0/1
                     [115/20] via 191.1.1.9, Serial0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L2    10.1.2.0/24 [115/20] via 191.1.1.21, Serial0/1
i L2    10.1.1.0/24 [115/20] via 191.1.1.9, Serial0/0
i L2    10.1.2.2/32 [115/20] via 191.1.1.21, Serial0/1
i L2 192.168.0.0/24 [115/20] via 191.1.1.9, Serial0/0
i L2 192.168.1.0/24 [115/20] via 191.1.1.17, Serial0/2
C    192.168.2.0/24 is directly connected, FastEthernet0/0
R4#
R4#sh clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R1             Se0/1       *PPP*               Up     26        L2   IS-IS
R2             Se0/2       *PPP*               Up     24        L2   IS-IS
R3             Se0/0       *PPP*               Up     24        L2   IS-IS
R8             Fa0/0       c007.04fc.0000      Up     7         L1   IS-IS
R4#

----------

R8#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.2.2 to network 0.0.0.0

     191.1.0.0/30 is subnetted, 3 subnets
i L1    191.1.1.20 [115/20] via 192.168.2.2, FastEthernet0/0
i L1    191.1.1.16 [115/20] via 192.168.2.2, FastEthernet0/0
i L1    191.1.1.8 [115/20] via 192.168.2.2, FastEthernet0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] via 192.168.2.2, FastEthernet0/0
R8#

R8#sh clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R4             Fa0/0       c003.12ac.0000      Up     27        L1   IS-IS
R8#

----------
R9# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     191.1.0.0/16 is variably subnetted, 8 subnets, 2 masks
i L2    191.1.1.20/30 [115/30] via 192.168.1.2, FastEthernet0/0
i L2    191.1.1.16/30 [115/20] via 192.168.1.2, FastEthernet0/0
i L2    191.1.1.13/32 [115/20] via 192.168.1.2, FastEthernet0/0
i L2    191.1.1.12/30 [115/20] via 192.168.1.2, FastEthernet0/0
i L2    191.1.1.8/30 [115/30] via 192.168.1.2, FastEthernet0/0
i L2    191.1.1.4/30 [115/20] via 192.168.1.2, FastEthernet0/0
i L2    191.1.1.1/32 [115/30] via 192.168.1.2, FastEthernet0/0
i L2    191.1.1.0/30 [115/30] via 192.168.1.2, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L2    10.1.2.0/24 [115/30] via 192.168.1.2, FastEthernet0/0
i L2    10.1.1.0/24 [115/30] via 192.168.1.2, FastEthernet0/0
i L2    10.1.2.2/32 [115/30] via 192.168.1.2, FastEthernet0/0
i L2 192.168.0.0/24 [115/30] via 192.168.1.2, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
i L2 192.168.2.0/24 [115/30] via 192.168.1.2, FastEthernet0/0
R9#

R9#show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R2             Fa0/0       c001.12ac.0000      Up     29        L2   IS-IS
R9#

----------------
R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.1.2 to network 0.0.0.0

     191.1.0.0/30 is subnetted, 3 subnets
i L1    191.1.1.8 [115/20] via 10.1.1.2, FastEthernet0/0
i L1    191.1.1.4 [115/20] via 10.1.1.2, FastEthernet0/0
i L1    191.1.1.0 [115/20] via 10.1.1.2, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
i L1 192.168.0.0/24 [115/20] via 10.1.1.2, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] via 10.1.1.2, FastEthernet0/0
R5#
System Id      Interface   SNPA                State  Holdtime  Type Protocol
R3             Fa0/0       c002.12ac.0001      Up     29        L1   IS-IS
R5#

------------------

remarque : les routeurs level 1-only R5, R6, R8 n'ont qu'une route par defaut pour des liens non directement connectés à leur voisin clns.


















 

Pour être informé des derniers articles, inscrivez vous :
Commenter cet article